[Gateway Whiz]Connecting an AR to an Alcatel DSLAM Through a G.SHDSL Interface Highlighted

Created: Feb 23, 2017 15:08:36Latest reply: Feb 23, 2017 16:25:12 1506 1 0 0

Overview

ARs provide a variety of WAN interfaces to meet customer requirements and can be connected to Digital Subscriber Line Access Multiplexers (DSLAMs) of multiple vendors. The primary/backup link scenario of xDSL (ADSL, VDSL, and G.SHDSL) low-speed links and 3G/4G wireless links is widely used.

ADSL

ADSL is a data communications technology that enables fast data transmission over copper twisted pairs by employing high frequencies that are not used by regular telephone lines.

VDSL

ADSL provides limited bandwidth for image services at high costs, which hinders ADSL development. VDSL is the most advanced digital subscriber line technology that provides high bandwidth for broadband services such as image services.

G.SHDSL

G.SHDSL is a data communications technology that enables faster data transmission over copper twisted pairs. G.SHDSL employs frequencies that include those unused by traditional Plain Old Telephone Service (POTS) to provide symmetric transmit and receive data rates.

Asymmetric Digital Subscriber Line (ADSL) is the most commonly used broadband access technology. It provides asymmetric transmit and receive data rates over copper twisted pairs and is useful for transmitting asymmetric services such as Internet access and Video on Demand (VoD). However, ADSL cannot meet requirements of commercial broadband applications that require bidirectional and symmetric traffic and are sensitive to performance fluctuation. The G.SHDSL technology solves this problem.

G.SHDSL complies with ITU Recommendation G.991.2 and provides bidirectional data transmission with symmetric data rates over twisted pairs. It reduces the transmission spectrum, improves the anti-noise performance, and extends the maximum transmission distance to 6 km by using 16-trellis coded pulse amplitude modulation (TCPAM).

xDSL System

As shown in Figure 1, a xDSL system consists of a Digital Subscriber Line Access Multiplexer (DSLAM) and Customer Premises Equipment (CPE).

  • A DSLAM is an aggregation device that terminates xDSL packets on the central office.
  • A CPE provides interfaces for users, modulates and demodulates data signals, and uploads user data to a DSLAM.
 NOTE:

The router functions as a CPE.

In the xDSL system, downstream transmission refers to data transmission from a DSLAM to a CPE, and upstream transmission refers to data transmission from a CPE to a DSLAM. xDSL interfaces on the device are upstream interfaces.

Figure 1 xDSL system
20170223151305946001.png

Configuration Notes

  • When an AR is connected to a DSLAM of a different vendor (Selta, Alcatel, or Siemens for example) through the primary link (ADSL, VDSL, or G.SHDSL link), ensure that parameter settings on both ends are consistent because DSLAMs of different vendors use different chips and inconsistent default parameters. This ensures successful interconnection between the AR and DSLAM.
  • Table 1 lists the matching product models and versions.
    Table 1 Matching product models and versions

    Vendor

    Model

    Version

    Huawei

    AR1200&AR2200&AR3200&AR3600 series routers (installed with 4G.SHDSL cards)

    V200R002C00SPC100 and later

    Alcatel

    DSLAM

    Unknown

 

Networking Requirements

In Figure 2, the Router is an enterprise branch gateway and is connected to an Alcatel DSLAM through a G.SHDSL interface, providing the primary link to connect to the Internet.

Services of this enterprise branch require high network connectivity. Because short network interruptions may affect services, the network backup solution is important for the enterprise branch. Deploying wired network access is time-consuming and costly, while deploying 3G access is simple and flexible. Therefore, this enterprise branch decides to use a 3G interface as a backup interface to connect to the Internet. When the primary link fails, traffic is switched to the backup link, improving Internet access reliability of the enterprise branch.

Figure 2 Configuring a G.SHDSL interface as the primary interface and a 3G interface as the backup interface to connect to the Internet
20170223152058372001.png
 

Configuring the Router

Configuration Roadmap

  1. Configure the enterprise intranet and configure the Router to assign IP addresses to intranet users.
  2. Configure a G.SHDSL interface as the primary interface.
  3. Configure a 3G interface as the backup interface.
  4. Configure default routes of the primary and backup interfaces so that intranet traffic can be transmitted to the Internet through the G.SHDSL and 3G interfaces.

Procedure

  1. Configure the enterprise intranet.

    # Create VLAN 20 and add Ethernet0/0/1 to VLAN 20.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan 20
    [Router-vlan20] quit
    [Router] interface ethernet 0/0/1
    [Router-Ethernet0/0/1] port link-type trunk
    [Router-Ethernet0/0/1] port trunk allow-pass vlan 20
    [Router-Ethernet0/0/1] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool pool_voce
    [Router-ip-pool-pool_voce] network 192.168.2.0 mask 255.255.255.0
    [Router-ip-pool-pool_voce] gateway-list 192.168.2.1
    [Router-ip-pool-pool_voce] dns-list 192.168.2.1
    [Router-ip-pool-pool_voce] quit

    # Assign IP addresses from the global address pool to users connected to VLANIF 20.

    [Router] interface vlanif 20
    [Router-Vlanif20] ip address 192.168.2.1 255.255.255.0
    [Router-Vlanif20] dhcp select global
    [Router-Vlanif20] quit

    # Configure allowed data flows in the enterprise intranet.

    [Router] acl number 2001
    [Router-acl-basic-2001] rule permit source 192.168.2.0 0.0.0.255
    [Router-acl-basic-2001] quit
    [Router] acl number 2002
    [Router-acl-basic-2002] rule permit source 192.168.0.0 0.0.0.255
    [Router-acl-basic-2002] quit

  2. Configure the G.SHDSL interface as the primary interface to connect to the Internet.

    # Set the transfer mode of the G.SHDSL interface to PTM.

    [Router] set workmode slot 1 shdsl ptm
    Info: Changing the working mode will reset the board in slot 1. Continue? [y/n]:
    y                                                                               
    INFO: Resetting board[1] succeeded. 

    # Deactivate Ethernet1/0/0 and Ethernet1/0/1.

    [Router] interface ethernet 1/0/0
    [Router-Ethernet1/0/0] shutdown
    [Router-Ethernet1/0/0] quit
    [Router] interface ethernet 1/0/1
    [Router-Ethernet1/0/1] shutdown
    [Router-Ethernet1/0/1] quit

    # Configure the G.SHDSL to work in CPE (client) mode (the default mode).

    # Bind the G.SHDSL interface to Ethernet1/0/0 and Ethernet1/0/1 in EFM mode. The number of the first interface to be bound must be 0 or 2.
    [Router] interface ethernet 1/0/0
    [Router-Ethernet1/0/0] shdsl bind efm 2

    # Set the modulation mode of the G.SHDSL interface to 16 PAM. The default modulation mode is auto, and the 16 PAM mode can be automatically delivered based on the modulation mode of the remote end.

    [Router-Ethernet1/0/0] shdsl pam 16

    # Activate Ethernet1/0/0 and Ethernet1/0/1.

    [Router-Ethernet1/0/0] undo shutdown
    [Router-Ethernet1/0/0] quit
    [Router] interface ethernet 1/0/1
    [Router-Ethernet1/0/1] undo shutdown
    [Router-Ethernet1/0/1] quit

    # Configure IP addresses for G.SHDSL sub-interfaces.

    [Router] interface ethernet 1/0/0.1035
    [Router-Ethernet1/0/0.1035] ip address 11.0.0.2 24
    [Router-Ethernet1/0/0.1035] dot1q termination vid 1035
    [Router-Ethernet1/0/0.1035] discard srr
    [Router-Ethernet1/0/0.1035] nat outbound 2001
    [Router-Ethernet1/0/0.1035] quit
    [Router] interface ethernet 1/0/0.1036
    [Router-Ethernet1/0/0.1036] ip address 13.0.0.3 25
    [Router-Ethernet1/0/0.1036] dot1q termination vid 1036
    [Router-Ethernet1/0/0.1036] discard srr
    [Router-Ethernet1/0/0.1036] nat outbound 2002
    [Router-Ethernet1/0/0.1036] quit

  3. Configure the 3G interface as the backup interface to connect to the 3G network.

    # Configure C-DCC for the dial-up connection.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate
    [Router-Cellular0/0/0] ppp ipcp dns request
    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] dialer-group 1
    [Router-Cellular0/0/0] dialer number *99#
    [Router-Cellular0/0/0] nat outbound 2002
    [Router-Cellular0/0/0] quit

    # Configure an NQA test instance.

    [Router] nqa test-instance user test
    [Router-nqa-user-test] test-type icmp
    [Router-nqa-user-test] destination-address ipv4 11.0.0.1
    [Router-nqa-user-test] probe-failtimes 5
    [Router-nqa-user-test] fail-percent 33
    [Router-nqa-user-test] frequency 35
    [Router-nqa-user-test] interval seconds 2
    [Router-nqa-user-test] timeout 2
    [Router-nqa-user-test] probe-count 15
    [Router-nqa-user-test] start now
    [Router-nqa-user-test] quit

    # Configure association between interface backup and NQA on the backup interface.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] standby track nqa user test
    [Router-Cellular0/0/0] standby timer delay 20 65
    [Router-Cellular0/0/0] quit

  4. Configure two default routes.

    [Router] ip route-static 0.0.0.0 0.0.0.0 13.0.0.1 track nqa voice wan_connected_check
    [Router] ip route-static 0.0.0.0 0.0.0.0 cellular 0/0/0 preference 100

Configuring the Alcatel DSLAM

Configuration Roadmap

  1. Configure the SHDSL interface type, including the transmission rate, line rate, and modulation mode.
  2. Configure a service model.

Procedure

  1. Configure the SHDSL interface type.

    # Activate the SHDSL interface.

    configure interface port shdsl-line:1/1/19/2 admin-up link-updown-trap user FREE

    # Configure VLAN-Port 1036 and VLAN-Port 1035.

    configure interface port vlan-port:1/1/19/2:1036 admin-up severity no-value
    configure interface port vlan-port:1/1/19/2:1035 admin-up severity no-value
    # Set the transfer mode of the SHDSL interface to EFM, line rate to 1536 kbps-2304 kbps, and modulation mode to 16 PAM. The EFM mode corresponds to the PTM mode of the G.SHDSL interface on the Huawei AR. On the Huawei AR, the default modulation mode is auto, and the 16 PAM mode can be automatically delivered based on the modulation mode of the remote end.
    configure shdsl span 1/1/19/2 active admin-up op-mode efm min-line-rate 1536 max-line-rate 2304 tc-pam-sele tc-pam16 efm-hs-sele auto

  2. Configure a service model.

    # Limit the number of unicast MAC addresses.

    configure interface port shdsl-line:1/1/19/2 admin-up link-updown-trap user FREE

    # Configure VLAN translation and bind the QoS profile to the Alcatel DSLAM.

    configure bridge port 1/1/19/2 vlan-id 1035 tag single-tagged network-vlan 1602 vlan-scope local qos profile:trusted-port
    configure bridge port 1/1/19/2 vlan-id 1036 tag single-tagged network-vlan 3602 vlan-scope local qos profile:trusted-port

Verification

  1. Run the display interface ethernet 1/0/0 command on the Router. The command output shows that the G.SHDSL interface status is Up.
    <Router> display interface ethernet 1/0/0
    Ethernet1/0/0 current state : UP                                                
    Line protocol current state : UP
    
  2. Run the show interface port shdsl-line:1/1/19/2 command on the DSLAM. The command output shows that the interface status is active.
  3. The enterprise branch can ping the headquarters successfully through the G.SHDSL link.


 

Exception Handling

When devices on both ends cannot ping each other, run the display dsl interface ethernet 1/0/0 command to check negotiation parameter settings of the G.SHDSL interface and ensure that the parameter settings are consistent with those of the remote end.

<Router> display dsl interface ethernet 1/0/0
 -------------------------------------------------------------------            
  Operating mode                                  :CPE                          
  Port admin status                               :Active                       
  Port running status                             :Activating                   
  Port bind status                                :EFM-2                        
  Bind group master port                          :0                            
  Port transmission mode                          :G.991.2 Annex A&B&F&G        
  Port power spectral density                     :Symmetric                    
  Port line probe                                 :Enable                       
  Inventory of SHDSL port 0                                                     
  Vendor ID                                       :Infineon                     
  Vendor mode                                     :SOCRATES                     
  Vendor serial                                   :4e_2e_1e                     
  EOC version                                     :0                            
  Standard version                                :8                            
  Vendor list                                     :-                            
  Vendor issue                                    :1                            
  Software code                                   :1.7.5                        
  Equipment code                                  :-                            
  Information of other vendor                     :V200R005                     
  Transmission mode capability                    :G.991.2 Annex A&B&F&G        
  Current 15 minutes statistic of SHDSL port 0                                  
  Total seconds counted in 15 minutes             :825                          
  ES count in 15 minutes (unit:Second)            :0                            
  SES count in 15 minutes (unit:Second)           :0                            
  CRC anomaly count in 15 minutes                 :0                            
  LOSW count in 15 minutes (unit:Second)          :0                            
  UAS count in 15 minutes (unit:Second)           :825                          
 -------------------------------------------------------------------

This post was last edited by 关关系列 at 2017-02-23 15:23.
  • x
  • convention:

gululu     Created Feb 23, 2017 16:25:12 Helpful(0) Helpful(0)

thanks!
  • x
  • convention:

Come on!

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top