Example for Configuring SEP and MSTP on a Network

Created Feb 28, 2019 16:55:54 10 0 0 0

Overview

Generally, redundant links are used to provide link backup and enhance network reliability. The use of redundant links, however, may produce loops. Loops cause infinite looping of packets, leading to broadcast storms and MAC address table instability. As a result, the communication quality deteriorates, and communication services may be interrupted. To block redundant links and ensure that they can be restored immediately to resume communication when a link fault occurs on a ring network, you can deploy SEP and MSTP on the ring network.

Configuration Notes

This example applies to all versions of all S series switches.

Networking Requirements

Company A needs to deploy multiple Layer 2 access devices. In Figure 6-32, Layer 2 switching devices form a ring at the access layer, and Layer 3 devices form a ring at the aggregation layer. The aggregation layer uses MSTP to eliminate redundant links. Company A requires that services be rapidly switched to prevent traffic interruption when a link at the access layer fails.

You can deploy multiple Layer 2 devices in a ring and configure SEP to meet the following requirements of company A:

  • When there is no faulty link on the ring network, SEP can eliminate loops.

  • When a link fails on the ring network, SEP can quickly restore communication between nodes in the ring.

  • The topology change notification function is configured on an edge device in a SEP segment so that devices on the upper-layer network can promptly detect topology changes on the lower-layer network. After receiving a topology change notification from a lower-layer network, a device on an upper-layer network sends a TC packet to instruct other devices to delete original MAC addresses and learn new MAC addresses. This ensures nonstop traffic forwarding.

Figure 6-32  SEP and MSTP networking 
imgDownload?uuid=f0eec24630d544e182123b3
imgDownload?uuid=eae83b7300b345b29127975 NOTE:

In this example, NPE1 and NPE2 use NE40Es running V600R008C00.

To ensure reliability of the entire network, you are advised to configure the following functions:
  • VRRP group between NPE1 and NPE2 to improve device-level reliability

  • BFD session between NPE1 and NPE2 to detect the link status and therefore implement fast switchover in the VRRP group

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic SEP functions.

    1. Configure SEP segment 1 on LSW1 to LSW3 and configure VLAN 10 as the control VLAN of SEP segment 1.

    2. Add LSW1 to LSW3 to SEP segment 1 and configure interface roles on edge devices (LSW1 and LSW2) of the SEP segment.

      imgDownload?uuid=eae83b7300b345b29127975 NOTE:

      PE1 and PE2 do not support the SEP protocol; therefore, the interfaces of LSW1 and LSW2 connected to the PEs must be no-neighbor edge interfaces.

    3. On the device where the no-neighbor primary edge interface is located, specify the interface in the middle of the SEP segment as the interface to block.

    4. Configure manual preemption.

    5. Configure the topology change notification function so that the upper-layer network running MSTP can be notified of topology changes in the SEP segment.

  2. Configure basic MSTP functions.

    1. Add PE1 to PE4, LSW1, and LSW2 to the MST region RG1.

    2. Create VLANs on PE1 to PE4, LSW1, and LSW2 and add interfaces on the STP ring to the VLANs.

    3. Configure PE3 as the root bridge and PE4 as the secondary root bridge.

  3. Set up a single-hop BFD session between NPE1 and NPE2 to detect the status of the interfaces configured with VRRP. Then, report the detection result to VRRP to complete VRRP fast switching.

  4. Configure VRRP.

    1. Create VRRP group 1 on GE 1/0/1 of NPE1, and set a higher VRRP priority for NPE1 to ensure that NPE1 functions as the master.

    2. Create VRRP group 1 in the view of GE 1/0/1 interface of NPE2, and allow NPE2 to use the default VRRP priority.

    3. Bind a BFD session to VRRP group 1.

  5. Configure Layer 2 forwarding on the CE and LSW1 to LSW3.

imgDownload?uuid=eae83b7300b345b29127975 NOTE:

PE1 and PE2 are aggregation switches, PE3 is the root bridge, PE4 is the secondary root bridge, LSWs are access switches, and CEs are user-side switches.

Procedure

  1. Configure basic SEP functions.

    1. Configure SEP segment 1 on LSW1 to LSW3 and configure VLAN 10 as the control VLAN of SEP segment 1.

      # Configure access switch LSW1.

      <HUAWEI> system-view[HUAWEI] sysname LSW1[LSW1] sep segment 1 //Create SEP segment 1.[LSW1-sep-segment1] control-vlan 10 //Configure VLAN 10 as the control VLAN of SEP segment 1.[LSW1-sep-segment1] protected-instance all //Configure all protected instances of SEP segment 1.[LSW1-sep-segment1] quit

      # Configure access switch LSW2.

      <HUAWEI> system-view[HUAWEI] sysname LSW2[LSW2] sep segment 1 //Create SEP segment 1.[LSW2-sep-segment1] control-vlan 10 //Configure VLAN 10 as the control VLAN of SEP segment 1.[LSW2-sep-segment1] protected-instance all //Configure all protected instances of SEP segment 1.[LSW2-sep-segment1] quit

      # Configure access switch LSW3.

      <HUAWEI> system-view[HUAWEI] sysname LSW3[LSW3] sep segment 1 //Create SEP segment 1.[LSW3-sep-segment1] control-vlan 10 //Configure VLAN 10 as the control VLAN of SEP segment 1.[LSW3-sep-segment1] protected-instance all //Configure all protected instances of SEP segment 1.[LSW3-sep-segment1] quit
      imgDownload?uuid=eae83b7300b345b29127975 NOTE:
      • The control VLAN must be a VLAN that has not been created or used. However, the command for creating a common VLAN is automatically displayed in the configuration file after the control VLAN is created.

      • Each SEP segment must have a control VLAN. After an interface is added to a SEP segment that has a control VLAN, the interface is automatically added to the control VLAN.

    2. Add access switch LSW1 to LSW3 to SEP segment 1 and configure interface roles.

      imgDownload?uuid=eae83b7300b345b29127975 NOTE:

      By default, STP is enabled on Layer 2 interfaces. Before adding an interface to a SEP segment, disable STP on the interface.

      # Configure access switch LSW1.

      [LSW1] interface gigabitethernet 1/0/1[LSW1-GigabitEthernet1/0/1] port link-type hybrid[LSW1-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor primary //Configure the interface as the no-neighbor primary edge interface and add it to SEP segment 1.[LSW1-GigabitEthernet1/0/1] quit[LSW1] interface gigabitethernet 1/0/2[LSW1-GigabitEthernet1/0/2] port link-type hybrid[LSW1-GigabitEthernet1/0/2] stp disable //Disable STP.[LSW1-GigabitEthernet1/0/2] sep segment 1 //Add the interface to SEP segment 1.[LSW1-GigabitEthernet1/0/2] quit

      # Configure access switch LSW2.

      [LSW2] interface gigabitethernet 1/0/1[LSW2-GigabitEthernet1/0/1] port link-type hybrid[LSW2-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor secondary //Configure the interface as the no-neighbor secondary edge interface and add it to SEP segment 1.[LSW2-GigabitEthernet1/0/1] quit[LSW2] interface gigabitethernet 1/0/2[LSW2-GigabitEthernet1/0/2] port link-type hybrid[LSW2-GigabitEthernet1/0/2] stp disable //Disable STP.[LSW2-GigabitEthernet1/0/2] sep segment 1 //Add the interface to SEP segment 1.[LSW2-GigabitEthernet1/0/2] quit

      # Configure access switch LSW3.

      [LSW3] interface gigabitethernet 1/0/1[LSW3-GigabitEthernet1/0/1] port link-type hybrid[LSW3-GigabitEthernet1/0/1] stp disable //Disable STP.[LSW3-GigabitEthernet1/0/1] sep segment 1 //Add the interface to SEP segment 1.[LSW3-GigabitEthernet1/0/1] quit[LSW3] interface gigabitethernet 1/0/2[LSW3-GigabitEthernet1/0/2] port link-type hybrid[LSW3-GigabitEthernet1/0/2] stp disable //Disable STP.[LSW3-GigabitEthernet1/0/2] sep segment 1 //Add the interface to SEP segment 1.[LSW3-GigabitEthernet1/0/2] quit
    3. Specify a blocking interface.

      # In SEP segment 1, set the mode of blocking an interface on access switch LSW1 where the no-neighbor primary edge interface is located to block the interface in the middle of the SEP segment.

      [LSW1] sep segment 1[LSW1-sep-segment1] block port middle
    4. Configure a preemption mode.

      # Configure manual preemption on access switch LSW1.

      [LSW1-sep-segment1] preempt manual
    5. Configure the SEP topology change notification function.

      Configure devices in SEP segment 1 to notify the MSTP network of topology changes.

      # Configure access switch LSW1.

      [LSW1-sep-segment1] tc-notify stp[LSW1-sep-segment1] quit

      # Configure access switch LSW2.

      [LSW2] sep segment 1[LSW2-sep-segment1] tc-notify stp[LSW2-sep-segment1] quit

  2. Configure basic MSTP functions.

    1. Configure an MST region.

      # Configure aggregation switch PE1.

      <HUAWEI> system-view[HUAWEI] sysname PE1[PE1] stp region-configuration //Enter the MST region view.[PE1-mst-region] region-name RG1 //Configure the MST region name as RG1.[PE1-mst-region] active region-configuration //Activate MST region configuration.[PE1-mst-region] quit

      # Configure aggregation switch PE2.

      <HUAWEI> system-view[HUAWEI] sysname PE2[PE2] stp region-configuration //Enter the MST region view.[PE2-mst-region] region-name RG1 //Configure the MST region name as RG1.[PE2-mst-region] active region-configuration //Activate MST region configuration.[PE2-mst-region] quit

      # Configure aggregation switch PE3.

      <HUAWEI> system-view[HUAWEI] sysname PE3[PE3] stp region-configuration //Enter the MST region view.[PE3-mst-region] region-name RG1 //Configure the MST region name as RG1.[PE3-mst-region] active region-configuration //Activate MST region configuration.[PE3-mst-region] quit

      # Configure aggregation switch PE4.

      <HUAWEI> system-view[HUAWEI] sysname PE4[PE4] stp region-configuration //Enter the MST region view.[PE4-mst-region] region-name RG1 //Configure the MST region name as RG1.[PE4-mst-region] active region-configuration //Activate MST region configuration.[PE4-mst-region] quit

      # Configure access switch LSW1.

      [LSW1] stp region-configuration //Enter the MST region view.[LSW1-mst-region] region-name RG1 //Configure the MST region name as RG1.[LSW1-mst-region] active region-configuration //Activate MST region configuration.[LSW1-mst-region] quit

      # Configure access switch LSW2.

      [LSW2] stp region-configuration //Enter the MST region view.[LSW2-mst-region] region-name RG1 //Configure the MST region name as RG1.[LSW2-mst-region] active region-configuration //Activate MST region configuration.[LSW2-mst-region] quit
    2. Create a VLAN and add interfaces on the ring network to the VLAN.

      # On aggregation switch PE1, create VLAN 100 and add GE1/0/1, GE1/0/2, and GE1/0/3 to VLAN 100.

      [PE1] vlan 100[PE1-vlan100] quit[PE1]interface gigabitethernet 1/0/1[PE1-GigabitEthernet1/0/1] port link-type hybrid[PE1-GigabitEthernet1/0/1] port hybrid tagged vlan 100[PE1-GigabitEthernet1/0/1] quit[PE1]interface gigabitethernet 1/0/2[PE1-GigabitEthernet1/0/2] port link-type hybrid[PE1-GigabitEthernet1/0/2] port hybrid tagged vlan 100[PE1-GigabitEthernet1/0/2] quit[PE1]interface gigabitethernet 1/0/3[PE1-GigabitEthernet1/0/3] port link-type hybrid[PE1-GigabitEthernet1/0/3] port hybrid tagged vlan 100[PE1-GigabitEthernet1/0/3] quit

      # On aggregation switch PE2, PE3, and PE4, create VLAN 100 and add GE1/0/1, GE1/0/2, and GE1/0/3 to VLAN 100.

      The configurations of aggregation switch PE2, PE3, and PE4 are similar to the configuration of aggregation switch PE1, and are not mentioned here. For details, see configuration files in this example.

      On access switch LSW1 and LSW2, create VLAN 100 and add GE1/0/1 to VLAN 100. The configurations of access switch LSW1 and LSW2 are similar to the configuration of aggregation switch PE1, and are not mentioned here. For details, see configuration files in this example.

    3. Enable MSTP.

      # Configure aggregation switch PE1.

      [PE1] stp enable

      # Configure aggregation switch PE2.

      [PE2] stp enable

      # Configure aggregation switch PE3.

      [PE3] stp enable

      # Configure aggregation switch PE4.

      [PE4] stp enable

      # Configure access switch LSW1.

      [LSW1] stp enable

      # Configure access switch LSW2.

      [LSW2] stp enable
    4. Configure aggregation switch PE3 as the root bridge and aggregation switch PE4 as the secondary root bridge.

      # Set the priority of aggregation switch PE3 to 0 in MSTI 0 to ensure that aggregation switch PE3 functions as the root bridge.

      [PE3] stp root primary

      # Set the priority of aggregation switch PE4 to 4096 in MSTI 0 to ensure that aggregation switch PE4 functions as the secondary root bridge.

      [PE4] stp root secondary

  3. Configure VLAN 100 to transmit VRRP packets and VLAN 200 to transmit BFD packets.

    # Configure aggregation switch PE3.

    [PE3] vlan batch 100 200[PE3] interface gigabitethernet 1/0/2[PE3-GigabitEthernet1/0/2] port link-type hybrid[PE3-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200[PE3-GigabitEthernet1/0/2] quit[PE3] interface gigabitethernet 1/0/3[PE3-GigabitEthernet1/0/2] port link-type hybrid[PE3-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200[PE3-GigabitEthernet1/0/2] quit

    # Configure aggregation switch PE4.

    [PE4] vlan batch 100 200[PE4] interface gigabitethernet 1/0/2[PE4-GigabitEthernet1/0/2] port link-type hybrid[PE4-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200[PE4-GigabitEthernet1/0/2] quit[PE4] interface gigabitethernet 1/0/3[PE4-GigabitEthernet1/0/3] port link-type hybrid[PE4-GigabitEthernet1/0/3] port hybrid tagged vlan 100 200[PE4-GigabitEthernet1/0/3] quit

  4. Configure a BFD session.

    1. Configure IP addresses for interfaces.

      # Configure an IP address for an interface on NPE1 and create a sub-interface for the interface.

      <HUAWEI> system-view[HUAWEI] sysname NPE1[NPE1] vlan 100[NPE1-vlan100] quit[NPE1] interface gigabitethernet 1/0/1[NPE1-GigabitEthernet1/0/1] undo shutdown[NPE1-GigabitEthernet1/0/1] ip address 10.2.1.1 24[NPE1-GigabitEthernet1/0/1] quit[NPE1] interface gigabitethernet 1/0/1.1[NPE1-GigabitEthernet1/0/1.1] undo shutdown[NPE1-GigabitEthernet1/0/1.1] vlan-type dot1q 100[NPE1-GigabitEthernet1/0/1.1] ip address 10.1.1.1 24[NPE1-GigabitEthernet1/0/1.1] quit

      # Configure an IP address for an interface on NPE2 and create a sub-interface for the interface.

      <HUAWEI> system-view[HUAWEI] sysname NPE2[NPE2] vlan 100[NPE2-vlan100] quit[NPE2] interface gigabitethernet 1/0/1[NPE2-GigabitEthernet1/0/1] undo shutdown[NPE2-GigabitEthernet1/0/1] ip address 10.2.1.2 24[NPE2-GigabitEthernet1/0/1] quit[NPE2] interface gigabitethernet 1/0/1.1[NPE2-GigabitEthernet1/0/1.1] undo shutdown[NPE2-GigabitEthernet1/0/1.1] vlan-type dot1q 100[NPE2-GigabitEthernet1/0/1.1] ip address 10.1.1.2 24[NPE2-GigabitEthernet1/0/1.1] quit
    2. Create a BFD session.

      # Enable BFD on NPE1 and configure a BFD session between NPE1 and NPE2.

      [NPE1] bfd[NPE1-bfd] quit[NPE1] bfd NPE2 bind peer-ip default-ip interface gigabitethernet 1/0/1 //Configure a static BFD session to monitor the link of the VRRP group.[NPE1-bfd-session-npe2] discriminator local 1[NPE1-bfd-session-npe2] discriminator remote 2[NPE1-bfd-session-npe2] commit[NPE1-bfd-session-npe2] quit

      # Enable BFD on NPE2 and configure a BFD session between NPE1 and NPE2.

      [NPE2] bfd[NPE2-bfd] quit[NPE2] bfd NPE1 bind peer-ip default-ip interface gigabitethernet 1/0/1 //Configure a static BFD session to monitor the link of the VRRP group.[NPE2-bfd-session-npe1] discriminator local 2[NPE2-bfd-session-npe1] discriminator remote 1[NPE2-bfd-session-npe1] commit[NPE2-bfd-session-npe1] quit

      # After completing the configuration, run the display bfd session all on NPE1 and NPE2. The command output shows that the BFD session is set up between NPE1 and NPE2 and its status is Up.

      Use the display on NPE1 as an example.

      [NPE1] display bfd session all--------------------------------------------------------------------------------
      Local Remote PeerIpAddr      State     Type        InterfaceName
      --------------------------------------------------------------------------------
      1     2      224.0.0.184     Up        S_IP_IF     GigabitEthernet1/0/1
      --------------------------------------------------------------------------------
           Total UP/DOWN Session Number : 1/0 
    3. Configure association between BFD status and sub-interface status.

      # Configure NPE1.

      [NPE1] bfd[NPE1-bfd] quit[NPE1] bfd NPE2[NPE1-bfd-session-npe2] process-interface-status sub-if[NPE1-bfd-session-npe2] commit[NPE1-bfd-session-npe2] quit

      # Configure NPE2.

      [NPE2] bfd[NPE2-bfd] quit[NPE2] bfd NPE1[NPE2-bfd-session-npe1] process-interface-status sub-if[NPE2-bfd-session-npe1] commit[NPE2-bfd-session-npe1] quit

      After completing the preceding configurations, run the display bfd session all verbose command on NPE1 and NPE2. Check that the Proc interface status field displays Enable (Sub-If).

      Use the display on NPE1 as an example.

      [NPE1] display bfd session all verbose--------------------------------------------------------------------------------
      Session MIndex : 257       (One Hop) State : Up        Name : npe2
      --------------------------------------------------------------------------------
        Local Discriminator    : 1                Remote Discriminator   : 2
        Session Detect Mode    : Asynchronous Mode Without Echo Function
        BFD Bind Type          : Interface(GigabitEthernet1/0/1)
        Bind Session Type      : Static
        Bind Peer IP Address   : 224.0.0.184
        NextHop Ip Address     : 224.0.0.184
        Bind Interface         : GigabitEthernet1/0/1
        FSM Board Id           : 0                TOS-EXP                : 7
        Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
        Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
        Local Detect Multi     : 3                Detect Interval (ms)   : 3000
        Echo Passive           : Disable          Acl Number             : -
        Destination Port       : 3784             TTL                    : 255
        Proc Interface Status  : Enable(Sub-If)   Process PST            : Disable
        WTR Interval (ms)      : -                Local Demand Mode      : Disable
        Active Multi           : 3
        Last Local Diagnostic  : No Diagnostic
        Bind Application       : IFNET
        Session TX TmrID       : 93               Session Detect TmrID   : 94
        Session Init TmrID     : -                Session WTR TmrID      : -
        Session Echo Tx TmrID  : -
        PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
        Session Description    : -
      --------------------------------------------------------------------------------
      
           Total UP/DOWN Session Number : 1/0 

  5. Configure VRRP.

    • # Configure an IP address for an interface on NPE1, create VRRP group 1, and set the VRRP priority of NPE1 to 120 so that NPE1 can function as the master.

      [NPE1] interface gigabitethernet 1/0/1.1[NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 virtual-ip 10.1.1.10[NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 priority 120 //The default priority of a device in a VRRP group is 100. Change the priority of the master to be higher than that of the backup.[NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 preempt-mode timer delay 10 //A device in a VRRP group uses immediate preemption by default. Change the preemption delay of the master to prevent service interruptions on an unstable network where devices in the VRRP group preempt to be the master.
    • # Configure an IP address for an interface on NPE2, create VRRP group 1, and allow NPE2 to use the default value so that NPE1 can function as the backup.

      [NPE2] interface gigabitethernet 1/0/1.1[NPE2-GigabitEthernet1/0/1.1] vrrp vrid 1 virtual-ip 10.1.1.10
    • # On NPE1, bind the VRRP group and the BFD session.

      [NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 track bfd-session 1 peer[NPE1-GigabitEthernet1/0/1.1] quit
    • # On NPE2, bind the VRRP group and the BFD session.

      [NPE2-GigabitEthernet1/0/1.1] vrrp vrid 1 track bfd-session 2 peer[NPE2-GigabitEthernet1/0/1.1] quit
    After completing the preceding configurations, run the display vrrp command on NPE1. Check that the status of NPE1 is Master. Run the display vrrp command on NPE2. Check that the status of NPE2 is Backup.
    [NPE1] display vrrpGigabitEthernet1/0/1.1 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.10
        Master IP      : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 10
        TimerRun : 1
        TimerConfig : 1
        Auth Type : NONE
        Virtual Mac :  0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Config track link-bfd down-number : 0
        Track BFD : 1  type: peer
        BFD-session state : UP
        Create time : 2013-12-29 22:46:32 UTC+07:00
        Last change time : 2013-12-29 22:46:35 UTC+07:00
    [NPE2] display vrrpGigabitEthernet1/0/1.1 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.10
        Master IP      : 10.1.1.2
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0
        TimerRun : 1
        TimerConfig : 1
        Auth Type : NONE
        Virtual Mac :  0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Config track link-bfd down-number : 0
        Track BFD : 2  type: peer
        BFD-session state : UP
        Create time : 2013-12-29 22:46:32 UTC+07:00
        Last change time : 2013-12-29 22:46:35 UTC+07:00

  6. Configure the Layer 2 forwarding function on the user-side switch CE and access switch LSW1 to LSW3.

    The configuration details are not mentioned here. For details, see configuration files in this example.

  7. Verify the configuration.

    After the configuration is complete and the network topology becomes stable, perform the following operations to verify the configuration.

    • # Run the shutdown command on GE1/0/1 of LSW2 to simulate a fault, and then run the display sep interface command on LSW3 to check whether GE1/0/2 on LSW3 changes from the discarding state to the forwarding state.

      <LSW3> display sep interface gigabitethernet 1/0/2SEP segment 1
      ----------------------------------------------------------------
      Interface           Port Role     Neighbor Status     Port Status
      ----------------------------------------------------------------
      GE1/0/2             common        up                  forwarding 
    • Run the shutdown command on GE 1/0/1.1 on NPE1 to simulate an interface fault, and then run the display vrrp command on NPE2 to check whether the status of NPE2 changes from backup to master.

      [NPE2] display vrrpGigabitEthernet1/0/1.1 | Virtual Router 1
          State : Master
          Virtual IP : 10.1.1.10
          Master IP      : 10.1.1.2
          PriorityRun : 100
          PriorityConfig : 100
           MasterPriority : 100
          Preempt : YES   Delay Time : 0
          TimerRun : 1
          TimerConfig : 1
          Auth Type : NONE
          Virtual Mac :  0000-5e00-0101
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Config track link-bfd down-number : 0
          Track BFD : 2  type: peer
          BFD-session state : DOWN  
          Create time : 2013-12-29 22:46:32 UTC+07:00
          Last change time : 2013-12-30 00:12:10 UTC+07:00

Configuration Files

  • LSW1 configuration file

    #
    sysname LSW1
    #
    vlan batch 10 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     block port middle
     tc-notify stp
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor primary 
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW2 configuration file

    #
    sysname LSW2
    #
    vlan batch 10 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     tc-notify stp
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor secondary
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW3 configuration file

    #
    sysname LSW3
    #
    vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/3 port link-type hybrid port hybrid tagged vlan vlan 100
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3 port link-type hybrid port hybrid tagged vlan 100
    #
    return            
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3 port link-type hybrid port hybrid tagged vlan 100
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    vlan batch 100
    #
    stp instance 0 root primary
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3 port link-type hybrid port hybrid tagged vlan 100 200
    #
    return
  • PE4 configuration file

    #
    sysname PE4
    #
    vlan batch 100
    #
    stp instance 0 root secondary
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2 port link-type hybrid port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3 port link-type hybrid port hybrid tagged vlan 100 200
    #
    return
  • NPE1 configuration file

    #
     sysname NPE1
    #
     vlan batch 100
    #
     bfd
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1.1
     vlan-type dot1q 100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 10
     vrrp vrid 1 track bfd-session 1 peer
    #
    bfd npe2 bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 1
     discriminator remote 2
     process-interface-status sub-if
     commit
    #
    return
  • NPE2 configuration file

    #
     sysname NPE2
    #
     vlan batch 100
    #
     bfd
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1.1
     vlan-type dot1q 100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
     vrrp vrid 1 track bfd-session 2 peer
    #
    bfd npe1 bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 2
     discriminator remote 1
     process-interface-status sub-if
     commit
    #
    return
  • CE configuration file
    #
    sysname CE
    #
    vlan batch 100
    #
    interface GigabitEthernet1/0/1 port link-type hybrid port hybrid tagged vlan 100
    #
    return

See more please click 

https://support.huawei.com/enterprise/en/doc/EDOC1000069520/9aadccc0/comprehensive-configuration-examples


  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top