Example for Configuring Routed Proxy ARP

196 0 0 0

Example for Configuring Routed Proxy ARP

Overview

When an enterprise network is divided into subnets, two subnets may belong to the same network segment but different physical networks. These two subnets are isolated by the switch. You can modify the routing information about the hosts on the network, so that the data packets destined for other subnets are sent to the gateway connected to different subnets and then forwarded by the gateway to the destination. However, to implement this solution, you must configure routes for all hosts on the subnets. This complicates management and maintenance.

Deploying routed proxy ARP on the gateway can effectively solve the management and maintenance problems in subnet division. Routed proxy ARP allows the communication between the hosts whose IP addresses belong to the same network segment but different physical networks. In addition, the default gateway does not need to be configured on the hosts, facilitating management and maintenance.

Configuration Notes

After routed proxy ARP is enabled on the device, reduce the aging time of ARP entries on hosts. In this way, the invalid ARP entries do not take effect as soon as possible, reducing the number of packets that are sent to but cannot be forwarded by the switch.

Table 7-1  Applicable product models and versions

Series

Product Model

Software Version

S1700

S1720GFR

V200R006C10, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S1720GW and S1720GWR

V200R010C00, V200R011C00, V200R011C10, V200R012C00

S1720GW-E and S1720GWR-E

V200R010C00, V200R011C00, V200R011C10, V200R012C00

S1720X and S1720X-E

V200R011C00, V200R011C10, V200R012C00

S2700

S2700EI

V100R006C05

S2710SI

V100R006C05

S2720EI

V200R006C10, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S2750EI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S3700

S3700SI and S3700EI

V100R006C05

S3700HI

V200R001C00

S5700

S5700LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700S-LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700SI

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-C-LI

V200R001C00

S5710-X-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710HI

V200R003C00, V200R005(C00&C02&C03)

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5720I-SI

V200R012C00

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5720HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5730HI

V200R012C00

S5730SI

V200R011C10, V200R012C00

S5730S-EI

V200R011C10, V200R012C00

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10, V200R012C00

S6720SI and S6720S-SI

V200R011C00, V200R011C10, V200R012C00

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S6720HI

V200R012C00

S7700

S7703, S7706, and S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9700

S9703, S9706, and S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

imgDownload?uuid=a3b3440bca934771aa9f94d NOTE:
For details about software mappings, visit Hardware Query Tool and search for the desired product model.

Networking Requirements

As shown in Figure 7-2, branch A and branch B of the enterprise are located in different cities and their host IP addresses belong to the same network segment 172.16.0.0/16. There are reachable routes between Switch_1 connected to branch A and Switch_2 connected to branch B. Branch A and branch B belong to different broadcast domains; therefore, they cannot communicate on a LAN. Hosts in the branches are not configured with default gateway addresses, so they cannot communicate across network segments. The enterprise requires that branch A and branch B communicate without changing the host configurations.

Figure 7-2  Networking diagram for configuring routed proxy ARP 
imgDownload?uuid=9abf3914c5874f1b9b8fa47

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add the interface connecting Switch_1 and branch A to VLAN 10 and add the interface connecting Switch_2 and branch B to VLAN 20.

  2. Enable routed proxy ARP on VLANIF interfaces of branch A and branch B to allow the two branches to communicate.

Procedure

  1. Create VLANs, add interfaces to VLANs, and configure IP addresses for the interfaces.

    # Configure Switch_1.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 10
    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port link-type access
    [Switch_1-GigabitEthernet1/0/1] port default vlan 10
    [Switch_1-GigabitEthernet1/0/1] quit
    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address 172.16.1.1 24
    

    # Configure Switch_2.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 20
    [Switch_2] interface gigabitethernet 1/0/1
    [Switch_2-GigabitEthernet1/0/1] port link-type access
    [Switch_2-GigabitEthernet1/0/1] port default vlan 20
    [Switch_2-GigabitEthernet1/0/1] quit
    [Switch_2] interface vlanif 20
    [Switch_2-Vlanif20] ip address 172.16.2.1 24
    

  2. Configure routed proxy ARP.

    # Configure Switch_1.

    [Switch_1-Vlanif10] arp-proxy enable  //Configure routed proxy ARP
    [Switch_1-Vlanif10] quit

    # Configure Switch_2.

    [Switch_2-Vlanif20] arp-proxy enable  //Configure routed proxy ARP
    [Switch_2-Vlanif20] quit

  3. Verify the configuration.

    # Check ARP entries of VLANIF 10 on Switch_1. The command output shows the MAC address mapping the IP address of VLANIF 10.

    [Switch_1] display arp interface vlanif 10
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                              VLAN/CEVLAN                                                                               
    ------------------------------------------------------------------------------                                                      
    172.16.1.1      101b-5441-5bf6            I -         Vlanif10                                                                     
    ------------------------------------------------------------------------------                                                      
    Total:1         Dynamic:0       Static:0     Interface:1  

    # Select Host_1 (using Windows 7 as an example) at 172.16.1.2/16 in branch A and select Host_2 at 172.16.2.2/16 in branch B. Ping the IP address of Host_2 on Host_1. The ping operation is successful.

    C:\Documents and Settings\Administrator> ping 172.16.2.2
    Pinging 172.16.2.2 with 32 bytes of data:
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.2.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    # Check the ARP table on Host_1. The command output shows that the MAC address mapping the IP address of Host_2 is the MAC address of VLANIF 10 on Switch_1, indicating that Host_1 and Host_2 can communicate with each other through ARP proxy.

    C:\Documents and Settings\Administrator> arp -a
    Interface: 172.16.1.2 --- 0xd
      Internet Address      Physical Address      Type
      172.16.2.2            101b-5441-5bf6        dynamic
    ...

Configuration Files

  • Switch_1 configuration file

    #
    sysname Switch_1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     arp-proxy enable
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    return
    
  • Switch_2 configuration file

    #
    sysname Switch_2
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 172.16.2.1 255.255.255.0
     arp-proxy enable
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 20
    #
    return
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top