Example for Configuring RIP Version

Created: Mar 16, 2016 17:37:19Latest reply: Mar 17, 2016 15:01:41 2067 1 0 0

Before using RIP, you need to configure basic RIP functions and specify a RIP version. You can run commands to view the configuration results.

Networking Requirements

As shown in Figure 3-1, it is required that RIP be enabled on all interfaces of Router A, Router B, Router C, and Router D and the routers interconnect with each other by using RIP-2.

Figure 3-1  Networking diagram for configuring the RIP version number

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface to ensure that neighboring nodes are reachable at the network layer.

  2. Enable RIP on each router and configure basic RIP functions.

  3. Configure RIP-2 on each router and check information about classless routes.

Data Preparation

To complete the configuration, you need the following data:

  • Network segment (192.168.1.0) to be enabled with RIP on Router A

  • Network segments (192.168.1.0, 172.16.0.0, and 10.0.0.0) to be enabled with RIP on Router B

  • Network segment (172.16.0.0) to be enabled with RIP on Router C

  • Network segment (10.0.0.0) to be enabled with RIP on Router D

  • RIP-2 on Router A, Router B, Router C, and Router D

Procedure

  1. Configure an IP address for each interface.

    The configuration details are not described here.

  2. Configure basic RIP functions.

    # Configure Router A.

    [RouterA] rip
    [RouterA-rip-1] network 192.168.1.0
    [RouterA-rip-1] quit

    # Configure Router B.

    [RouterB] rip
    [RouterB-rip-1] network 192.168.1.0
    [RouterB-rip-1] network 172.16.0.0
    [RouterB-rip-1] network 10.0.0.0
    [RouterB-rip-1] quit

    # Configure Router C.

    [RouterC] rip
    [RouterC-rip-1] network 172.16.0.0
    [RouterC-rip-1] quit

    # Configure Router D.

    [RouterD] rip
    [RouterD-rip-1] network 10.0.0.0
    [RouterD-rip-1] quit

    # Check the RIP routing table of Router A.

    [RouterA] display rip 1 route
     Route Flags: R - RIP, T - TRIP
                  A - Aging, G - Garbage-collect 
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on Pos1/0/0
          Destination/Mask        Nexthop     Cost   Tag     Flags   Sec
             172.16.0.0/16         192.168.1.2      1    0        RA      16
             10.0.0.0/8            192.168.1.2      1    0        RA      16

    The preceding display shows that the routes advertised by RIP-1 carry natural masks.

  3. Configure the RIP version number.

    # Configure RIP-2 on Router A.

    [RouterA] rip
    [RouterA-rip-1] version 2
    [RouterA-rip-1] quit

    # Configure RIP-2 on Router B.

    [RouterB] rip
    [RouterB-rip-1] version 2
    [RouterB-rip-1] quit

    # Configure RIP-2 on Router C.

    [RouterC] rip
    [RouterC-rip-1] version 2
    [RouterC-rip-1] quit

    # Configure RIP-2 on Router D.

    [RouterD] rip
    [RouterD-rip-1] version 2
    [RouterD-rip-1] quit
  4. Verify the configuration.

    # Check the RIP routing table of Router A.

    [RouterA] display rip 1 route
    Route Flags: R - RIP
                  A - Aging, G - Garbage-collect 
    -------------------------------------------------------------------------
     Peer 192.168.1.2  on Pos1/0/0
          Destination/Mask        Nexthop     Cost   Tag     Flags   Sec
             172.16.1.0/24       192.168.1.2      1    0        RA      32
             10.1.1.0/24         192.168.1.2      1    0        RA      32

    The preceding display shows that the routes advertised by RIPv2 carry subnet masks.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
    #
    interface Pos2/0/0
     link-protocol ppp
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
    #
    interface Pos3/0/0
     link-protocol ppp
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    rip 1
     version 2
     network 192.168.1.0
     network 172.16.0.0
     network 10.0.0.0
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    interface Pos2/0/0
     link-protocol ppp
     undo shutdown
     ip address 172.16.1.2 255.255.255.0
    #
    rip 1
     version 2
     network 172.16.0.0
    #
    return
  • Configuration file of Router D

    #
     sysname RouterD
    #
    interface Pos3/0/0
     link-protocol ppp
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    rip 1
     version 2
     network 10.0.0.0
    #
    return
  • x
  • convention:

SherryL     Created Mar 17, 2016 15:01:41 Helpful(0) Helpful(0)

Thank you.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top