Example for Configuring Link Aggregation in Manual Mode When Switches Are Directly Connected

Created Feb 28, 2019 16:20:59 6 0 0 0

Overview

Ethernet link aggregation increases link bandwidth by bundling multiple physical links to form a logical link. Link aggregation can work in manual mode or Link Aggregation Control Protocol (LACP) mode.

In manual mode, you must manually create an Eth-Trunk and add member interfaces to the Eth-Trunk. In this mode, LACP is not required. If a high link bandwidth between two directly connected devices is required but the remote device does not support LACP, you can use the manual mode. The manual mode can increase bandwidth, enhance reliability, and implement load balancing.

In manual mode, all active links forward data and load balance traffic.

Configuration Notes

  • Member interfaces of an Eth-Trunk must use the same Ethernet type and rate.
  • Both devices of the Eth-Trunk must use the same number of physical interfaces, interface rate, duplex mode, and flow control mode.
  • If an interface of the local device is added to an Eth-Trunk, an interface of the remote device directly connected to the interface of the local device must also be added to an Eth-Trunk. Otherwise, the two ends cannot communicate.
  • Both devices of an Eth-Trunk must use the same link aggregation mode.
  • This example applies to all versions of all S series switches.

Networking Requirements

In Figure 6-5SwitchA and SwitchB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between SwitchA and SwitchB.

SwitchA and SwitchB can provide higher link bandwidth to implement inter-VLAN communication. Data transmission and link reliability need to be ensured.

Figure 6-5  Networking for configuring link aggregation in manual mode 
imgDownload?uuid=c17cf88f0f8f49f993bfea2

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.

  2. Create VLANs and add interfaces to the VLANs.

  3. Set the load balancing mode to ensure that traffic is load balanced between member interfaces of the Eth-Trunk and enhance reliability.

Procedure

  1. Create an Eth-Trunk on SwitchA and SwitchB and add member interfaces to the Eth-Trunk.

    <HUAWEI> system-view[HUAWEI] sysname SwitchA[SwitchA] interface eth-trunk 1   //Create Eth-Trunk 1.[SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3   //Add GE0/0/1, GE0/0/2, and GE0/0/3 to Eth-Trunk 1.[SwitchA-Eth-Trunk1] quit
    <HUAWEI> system-view[HUAWEI] sysname SwitchB[SwitchB] interface eth-trunk 1   //Create Eth-Trunk 1.[SwitchB-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3   //Add GE0/0/1, GE0/0/2, and GE0/0/3 to Eth-Trunk 1.[SwitchB-Eth-Trunk1] quit

  2. Create VLANs and add interfaces to the VLANs.

    # Create VLAN 10 and VLAN 20 and add interfaces to them. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] vlan batch 10 20[SwitchA] interface gigabitethernet 0/0/4[SwitchA-GigabitEthernet0/0/4] port link-type trunk   //Configure the interface as a trunk interface. The default link type of an interface is not trunk.[SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 10[SwitchA-GigabitEthernet0/0/4] quit[SwitchA] interface gigabitethernet 0/0/5[SwitchA-GigabitEthernet0/0/5] port link-type trunk   //Configure the interface as a trunk interface. The default link type of an interface is not trunk.[SwitchA-GigabitEthernet0/0/5] port trunk allow-pass vlan 20[SwitchA-GigabitEthernet0/0/5] quit

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] port link-type trunk   //Configure the interface as a trunk interface. The default link type of an interface is not trunk.[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20[SwitchA-Eth-Trunk1] quit

  3. Set the load balancing mode of Eth-Trunk 1. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] load-balance src-dst-mac   //Configure load balancing based on the source and destination MAC addresses on Eth-Trunk 1.[SwitchA-Eth-Trunk1] quit

  4. Verify the configuration.

    Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.

    [SwitchA] display eth-trunk 1Eth-Trunk1's state information is: 
    WorkingMode: NORMAL           Hash arithmetic: According to SA-XOR-DA
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8
    Operate status: up             Number Of Up Port In Trunk: 3 
    --------------------------------------------------------------------------------
    PortName                           Status       WeightGigabitEthernet0/0/1               Up           1GigabitEthernet0/0/2               Up           1GigabitEthernet0/0/3               Up           1

    The preceding information shows that Eth-Trunk 1 contains three member interfaces: GigabitEthernet0/0/1, GigabitEthernet0/0/2, and GigabitEthernet0/0/3. The member interface status is Up and the value of Operate status of Eth-Trunk 1 is up.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac
    # 
    interface GigabitEthernet0/0/1 
     eth-trunk 1
    # 
    interface GigabitEthernet0/0/2 
     eth-trunk 1
    # 
    interface GigabitEthernet0/0/3 
     eth-trunk 1
    #
    interface GigabitEthernet0/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac
    # 
    interface GigabitEthernet0/0/1 
     eth-trunk 1
    # 
    interface GigabitEthernet0/0/2 
     eth-trunk 1
    # 
    interface GigabitEthernet0/0/3 
     eth-trunk 1
    #
    interface GigabitEthernet0/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return

See more please click 

https://support.huawei.com/enterprise/en/doc/EDOC1000069520/9aadccc0/comprehensive-configuration-examples


  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top