Example for Configuring BFD for RIP

Created: Jan 14, 2017 23:23:55Latest reply: Jan 15, 2017 00:17:26 1100 1 0 0

Specifications

This example applies to all AR models of all versions.

Networking Requirements

In Figure 7-6, a company uses a L2 Switch as a relay agent to connect two departments that are far from each other. Router_1, Router_2, and Router_3 run Routing Information Protocol (RIP) and establish RIP neighbor relationships to ensure that they are reachable at the network layer.

Router_3 does not support bidirectional forwarding detection (BFD). The company wants to configure BFD for RIP on Router_1 and use BFD echo packets to ensure that BFD can fast detect and notify RIP of the link failure between Router_1 (or Router_3) and the L2 Switch.

The company wants to configure BFD for RIP on Router_1 and Router_3 to meet the following requirements:
  • Detect the link that passes through the L2 Switch.
  • Ensure that the devices can fast detect and notify RIP of the link failure and switch traffic to the link of Router_2.
Figure 7-6  Networking diagram of configuring BFD for RIP
991da385126849bfb7d3a548ce5bf122
Device Interface IP Address
Router_1 GE2/0/1 10.1.0.101/24
GE2/0/2 10.10.0.101/24
GE2/0/3 10.20.1.1/24
Router_2 GE2/0/1 10.10.0.102/24
GE2/0/2 10.40.1.101/24
Router_3 GE2/0/1 10.1.0.102/24
GE2/0/2 10.40.1.102/24
GE2/0/3 10.30.1.1/24

Procedure

  1. Configure Router_1.

    #
     sysname Router_1
    #
    bfd
    #
    interface GigabitEthernet2/0/1
     ip address 10.1.0.101 255.255.255.0
     rip bfd static
    #
    interface GigabitEthernet2/0/2
     ip address 10.10.0.101 255.255.255.0
    #
    interface GigabitEthernet2/0/3
     ip address 10.20.1.1 255.255.255.0
    #
    rip 1    //Configure basic RIP functions on Router_1.
     version 2
     network 10.0.0.0
    #
    bfd 1 bind peer-ip 10.10.0.102 interface GigabitEthernet2/0/1 one-arm-echo    //Configure the BFD echo function on Router_1.
     discriminator local 1
     min-echo-rx-interval 200
    commit
    #
    return

  2. Configure Router_2.

    #
     sysname Router_2
    #
    interface GigabitEthernet2/0/1
     ip address 10.10.0.102 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     ip address 10.40.1.101 255.255.255.0
    #
    rip 1    //Configure basic RIP functions on Router_2.
     version 2
     network 10.10.0.0
     network 10.40.1.0
    #
    return

  3. Configure Router_3.

    #
     sysname Router_3
    #
    interface GigabitEthernet2/0/1
     ip address 10.1.0.102 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     ip address 10.40.1.102 255.255.255.0
    #
    interface GigabitEthernet2/0/3
     ip address 10.30.1.1 255.255.255.0
    #
    rip 1    //Configure basic RIP functions on Router_3.
     version 2
     network 10.1.0.0
     network 10.40.1.0
    #
    return

  4. Verify the configuration.

    • Run the display rip 1 bfd session all command on Router_1 to check BFD session information. The command output shows that a BFD session has been set up and is in Up state.
    • Run the display ip routing-table command on Router_1 to check routes to 10.30.1.0/24. The command output shows that packets from Router_1 are forwarded to Router_3 through the L2 Switch.

  • x
  • convention:

user_2790689     Created Jan 15, 2017 00:17:26 Helpful(0) Helpful(0)

thank you
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top