Dot1q-tunnel over etherchannel

Created Apr 08, 2016 04:44:58Latest reply Apr 08, 2016 19:37:09 2359 4 0 0

Hello everyone:

I have a doubt about one scenario. The thing is that i want to move some traffic on a switch, and the for that i had been able is using dot1q-tunnel.

1. First of all, traffic contain some vlans, and vlans must been transparent for my configuration, i dont need to know the vlans that passes through my switch.

2. I don´t have more equipment to do that, only i have a capable switch with high performance. On the simulation i will add 3 more switches and PCs for testing.

And this is the scenario:

On LSW4: 

vlan batch 10 20

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 20
mode lacp-static
#
interface GigabitEthernet0/0/1
eth-trunk 1
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/4
eth-trunk 1

LSW1(MY EQUIPMENT):

vlan batch 100 200

interface Eth-Trunk1
port link-type dot1q-tunnel
port default vlan 100
mode lacp-static
#
interface Eth-Trunk2
port link-type dot1q-tunnel
port default vlan 200
mode lacp-static
#
interface GigabitEthernet0/0/1
eth-trunk 1
#
interface GigabitEthernet0/0/2
eth-trunk 1
#
interface GigabitEthernet0/0/3
eth-trunk 2
#
interface GigabitEthernet0/0/4
eth-trunk 2
#
interface GigabitEthernet0/0/5
port link-type dot1q-tunnel
port default vlan 100
#
interface GigabitEthernet0/0/6
port link-type dot1q-tunnel
port default vlan 200

LSW5:

vlan batch 10 20

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 20
mode lacp-static
#
interface GigabitEthernet0/0/1
eth-trunk 1
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/4
eth-trunk 1

LSW2:

vlan batch 10 20

interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20

Client1: 10.10.10.1-------------vlan10

Client2: 10.10.20.1-------------vlan20

Client5: 10.10.10.10------------vlan10

Client6: 10.10.20.20------------vlan20

The problem: If the scenario is without the ether-channels, traffic travel like the red arrow, no problem, the rigth side can communicate with the left only across the switch located at the button, i can guarantee that, the simulation works nice!!!. Now, when i add one link on the tow side and configure an ether-channel, ping do not reach the destination, eg: ping from CLIENT1 to CLIENT5 reach LSW1, goes down to LSW2, then goes UP again to LSW1 by g0/0/2-g0/0/6 link AND STOP THERE. Traffic never leaves LSW1. 

Someone has tried that, please said if i am wrong with that, if eNSP is not able to do that, or if i am missing something


  • x
  • convention:

user_2790689  Expert   Created Apr 08, 2016 13:57:33 Helpful(0) Helpful(0)

waiting for expert to help you.
  • x
  • convention:

lizhuzhu     Created Apr 08, 2016 16:53:44 Helpful(0) Helpful(0)

I think there's something wrong with your topology. LSW1 and LSW2 become loop, there will be mac-flapping between these two LSW.

  • x
  • convention:

who_knows  Mentor   Created Apr 08, 2016 17:06:07 Helpful(0) Helpful(0)

ENSP cannot support QinQ feature now.
  • x
  • convention:

ogh     Created Apr 08, 2016 19:37:09 Helpful(0) Helpful(0)

Reply 3 #

I can guarantee that my first explanation works pretty well, no mac-address flapping happens because from LSW1 point of view, g0/0/5 and g0/0/6 are access ports of differents VLANS, and LSW2, it´s not a switch at all, only i put a switch on mi simulation for testing purpose. Again, no flapping record of a mac-address happens, no trap, nothing.

  • x
  • convention:

Responses

Reply
You need to log in to reply to the post Login | Register

Notice:To ensure the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but not limited to politically sensitive content, content concerning pornography, gambling, drug abuse and trafficking, content that may disclose or infringe upon others' intellectual properties, including commercial secrets, trade marks, copyrights, and patents, and personal privacy. Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see“ Privacy Policy.”
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top