Configuring console server with ARG2

Created: Jan 31, 2015 17:54:51Latest reply: Feb 2, 2015 09:27:35 2635 1 0 0

Hi there,

If you are looking to find an example about how to configure console server on AR this is the right thread. Before checking the configuration, let's check some points:

1. Make sure you router has a asynchronous serial card installed. Configure the Asynchronous interface as below.

#
interface Async1/0
async mode flow
undo detect dsr-dtr
#
interface Async1/1
async mode flow
undo detect dsr-dtr
#
.....

2. Configure redirection function for tty users:

user-interface tty 17
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5001
user-interface tty 18
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5002
........

Full configuration for AR28-10.

#
sysname AR28_10
#
cpu-usage cycle 1min
#
dialer-rule 1 ip permit
#
radius scheme system
#
domain system
#
local-user admin
password cipher N`C55QK<`=/Q=^Q`MAF4<1!!
service-type telnet terminal
level 3
service-type ftp
local-user huawei
password simple huawei
service-type ppp
#
interface Async1/0
async mode flow
undo detect dsr-dtr
#
interface Async1/1
async mode flow
undo detect dsr-dtr
#
interface Async1/2
async mode flow
undo detect dsr-dtr
#
interface Async1/3
async mode flow
undo detect dsr-dtr
#
interface Async1/4
async mode flow
undo detect dsr-dtr
#
interface Async1/5
async mode flow
undo detect dsr-dtr
#
interface Async1/6
async mode flow
undo detect dsr-dtr
shutdown
#
interface Async1/7
async mode flow
undo detect dsr-dtr
shutdown
#
interface ***ogmodem2/0
async mode protocol
link-protocol ppp
ppp authentication-mode pap
ppp pap local-user huawei password simple huawei
dialer bundle-member 1
remote address 192.168.10.200
#
interface Aux0
async mode flow
#
interface Dialer0
link-protocol ppp
ppp authentication-mode pap
ppp pap local-user huawei password simple huawei
ip address 192.168.10.254 255.255.255.0
dialer user huawei
dialer bundle 1
dialer-group 1
remote address 192.168.10.200
#
interface Ethernet0/0
shutdown
ip address dhcp-alloc
#
interface Serial0/0
clock DTECLK1
link-protocol ppp
shutdown
ip address dhcp-alloc
#
interface NULL0
#
interface LoopBack1
ip address 100.1.1.1 255.255.255.255
#
FTP server enable
#
user-interface con 0
user-interface tty 17
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5001
user-interface tty 18
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5002
user-interface tty 19
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5003
user-interface tty 20
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5004
user-interface tty 21
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5005
user-interface tty 22
undo shell
flow-control none
redirect enable
redirect return-deal from-telnet
redirect timeout 900
redirect listen-port 5006
user-interface tty 23 24
user-interface tty 33
authentication-mode scheme
modem call-in
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return

  • x
  • convention:

user_2790689     Created Feb 2, 2015 09:27:35 Helpful(0) Helpful(0)

Thank you.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Fast reply Scroll to top