5720HI OSPF Adjacency Highlighted

Created: Jan 31, 2018 19:58:39Latest reply: Dec 24, 2018 09:17:36 2487 16 0 0
  Rewarded Hi-coins: 0 (problem resolved)
Hi Experts,


I would like to configure OSPF between S5720HI and Cisco router.

I have gig interface.

How can I achieve this?

Thanks
  • x
  • convention:

gululu Created Feb 8, 2018 14:29:41
hi,msaltunsaray ! Did your question have been solved? If the following reply can solve it, please click the “best answer”,thanks! 
Featured Answers
Created Feb 2, 2018 14:29:27 Helpful(1) Helpful(1)

This post was last edited by uzairu at 2018-02-02 09:51. Please use "ip ospf network point-to-point" as well including " IP ospf mtu-ignore" as Jon_YX mentioned above secondly your loopback at cisco side seems with different IP segment and usually BAD packet are due to mismatch in IP subnet.

If provided solution doesn't work we really appreciate if you can share the diagram of your network with IP scheme as I have in production network one Cisco and Huawei router and both are working fine with above (IP ospf network point-to-point & IP ospf mtu-ignore).

Please do not hesitate to leave the message in case of any further assistance.
  • x
  • convention:

Kindest%20Regards%3Cbr%20%2F%3E%0AMuhammad%20Uzair%3Cbr%20%2F%3E%0AHCIE%20%236776
All Answers
msaltunsaray Created Jan 31, 2018 21:49:58 Helpful(0) Helpful(0)

My 5720Hi version is below:

Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600)
  • x
  • convention:

msaltunsaray Created Jan 31, 2018 21:52:04 Helpful(0) Helpful(0)

And my interface configuration:

interface GigabitEthernet0/0/24
undo portswitch
ip address 10.10.0.14 255.255.255.252
ospf network-type p2p
ospf enable 1 area 0.0.0.0

My problem is no peer to cisco device.
  • x
  • convention:

msaltunsaray Created Jan 31, 2018 23:34:02 Helpful(0) Helpful(0)

Btw, I get bad pkt rcvd on Cisco.
  • x
  • convention:

Jon_TX Created Jan 31, 2018 23:45:19 Helpful(0) Helpful(0)

one possible reason I can think of is MTU mismatch.
check the MTU on both sides.

Rating

Number of participants 1E-coins +2 Collapse Reasons
gululu + 2 Good!

View All scores

  • x
  • convention:

msaltunsaray Created Jan 31, 2018 23:57:21 Helpful(0) Helpful(0)

Posted by Jon_TX at 2018-01-31 15:45 one possible reason I can think of is MTU mismatch.check the MTU on both sides.
MTUs both 1500
  • x
  • convention:

Jon_TX Created Feb 1, 2018 00:52:12
you also need to enable OSPF globally on Huawei device. <switch> system-view [switch] ospf 1 [switch] area 0.0.0.0 
uzzi Created Feb 1, 2018 01:20:04 Helpful(0) Helpful(0)

This post was last edited by uzairu at 2018-01-31 20:21. The config should be as below.

on Cisco side please do the following under interface.

ip ospf network point-to-point
ip ospf mtu-ignore

On huawei side you have to configure this in global view.

ospf (process ID) 
area 0
network 10.10.0.14 0.0.0.0

and under the interface

ospf network-type p2p

This should work, if not please do not hesitate to leave the message.

Rating

Number of participants 1E-coins +3 Collapse Reasons
gululu + 3 Good!

View All scores

  • x
  • convention:

Kindest%20Regards%3Cbr%20%2F%3E%0AMuhammad%20Uzair%3Cbr%20%2F%3E%0AHCIE%20%236776
msaltunsaray Created Feb 1, 2018 22:41:04 Helpful(0) Helpful(0)

Posted by uzzi at 2018-01-31 17:20 The config should be as below.on Cisco side please do the following under interface.ip ospf network ...
Hi Muhammad,

Thanks for comments.

I have changed the network type to broadcast. As I mentioned before i get an error message on Cisco as "bad pkt rcvd".

I am sharing my huawei and cisco configs below,

Huawei:

interface GigabitEthernet0/0/24
undo portswitch
description "to-Abr1.thnlon.core-gi0/0/3"
ip address 10.10.0.14 255.255.255.252
ospf enable 1 area 0.0.0.0

ospf 1 router-id 10.10.1.1
area 0.0.0.0
network 10.10.0.12 0.0.0.3


Cisco:

interface GigabitEthernet0/0/3
ip address 10.10.0.13 255.255.255.252
ip ospf 1 area 0
speed 1000
no negotiation auto

router ospf 1
router-id 185.100.189.17
network 10.10.0.12 0.0.0.3 area 0

So no adjacency!!!!!!

  • x
  • convention:

Jon_TX Created Feb 2, 2018 01:57:57
try "ip ospf mtu-ignore" on the cisco side. i dont see that on your config. 
uzzi Created Feb 2, 2018 14:29:27 Helpful(1) Helpful(1)

This post was last edited by uzairu at 2018-02-02 09:51. Please use "ip ospf network point-to-point" as well including " IP ospf mtu-ignore" as Jon_YX mentioned above secondly your loopback at cisco side seems with different IP segment and usually BAD packet are due to mismatch in IP subnet.

If provided solution doesn't work we really appreciate if you can share the diagram of your network with IP scheme as I have in production network one Cisco and Huawei router and both are working fine with above (IP ospf network point-to-point & IP ospf mtu-ignore).

Please do not hesitate to leave the message in case of any further assistance.
  • x
  • convention:

Kindest%20Regards%3Cbr%20%2F%3E%0AMuhammad%20Uzair%3Cbr%20%2F%3E%0AHCIE%20%236776
msaltunsaray Created Feb 19, 2018 20:12:31 Helpful(0) Helpful(0)

Hi guys,

Thanks all for your help. Thanks also Muhammad.

The issue has been resolved.
  • x
  • convention:

12
Back to list

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top